Täpp till säkerhetshål i iOS med patch från Cydia

Sitter du på första generationens iPhone eller iPod Touch, eller har du inte uppgraderat till senaste iOS 4? Då har du ett allvarligt säkerhetshål i din enhet. Säkerhetshålet finns i iOS PDF-läsare, och låter kod, som kan vara skadlig, i PDF-filer köras. På webbsidor är det lätt att gömma PDF-filer i en liten osynlig ruta, och på så sätt kan en webplats alltså köra potentiellt skadlig kod utan att du vet om det. Apple täpte till detta säkerhetshål i senaste versionen av iOS, 4.0.2, men för användare med äldre enheter blir det problem. Hårdvaran i första generationens iPhone och iPod Touch håller inte måttet för iOS 4, anser Apple. Därmed utelämnas äldre enheter eftersom de inte kan ta del av den nya uppdateringen. Men för jailbreakade enheter finns en lösning. iPhone-Dev Team släppte i dagarna en fix, men bara för jailbreakade enheter. "Tills Apple själva gör något åt saken", som de säger. PDF Patch, som korrigeringen kallas, kan installeras genom Cydia. För att testa om korrigeringen fungerar kan du prova att gå in på jailbreakme.com i din iOS-enhet. Siten, som utnyttjar PDF-buggen för att jailbreaka enheter via Safari, visar bara en tom bakgrund när du försöker jailbreaka en skyddad enhet.